分析家公式网,免费股票公式,股票软件下载站 彩票99官方网站  |  用户 注册
红色百年博弈
  • 软件大小:8.00 KB
  • 推荐星级:
  • 更新时间:2018-10-21 04:24:19
  • 软件类别: 国产软件 / 飞狐公式
  • 软件语言:简体中文
  • 授权方式: 解密版
  • 联系方式:暂无联系方式
  • 官方主页: Home Page
  • 点击大图:  【一键转帖到论坛】
  • 插件情况:
  • 运行环境:Win9X/2000/XP/2003/
  • 相关Tags:股票公式 股票软件
  • (1)100%
    (0)0%

99平台:==

文件:红色百年博弈.alg
名称: 红色百年博弈  类别:技术指标
说明: {股票公式www.sportscountrycamp.com}
公式组: 百年公测

DRAWGBK(1,COLORRGB(0,0,30),COLORRGB(0,0,120),1);
N:=1020531;
M:=1090531;
上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),LINETHICK0,colorFFFFFF;
月:REF(MONTH,BARSCOUNT(CLOSE)-1),LINETHICK0,colorFF99FF;
日:REF(DAY,BARSCOUNT(CLOSE)-1),LINETHICK0,colorFF99FF;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'证券代码:'+STKLABEL),ALIGN4,colorFF99FF;
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,'                 所属板块:'+BLKNAME+'  发行价'+NUMTOSTR(FINANCE(51),2)+'元'+'  发行量'+NUMTOSTR(FINANCE(52),2)+'万股'+'\n'+'总股本'+NUMTOSTR(FINANCE(1),0)+'万股'+'  流通A股'+NUMTOSTR(FINANCE(7),0)+'万股'+'  净资产'+NUMTOSTR(FINANCE(35),2)+'亿元'+'  每股收益'+NUMTOSTR(FINANCE(33),2)+'元'+'  每股未分配'+NUMTOSTR(FINANCE(32),2)+'元'+'  市盈率'+NUMTOSTR(DYNAINFO(39),2)+'%'+'  投资收益'+NUMTOSTR(FINANCE(24),2)+'元'+'  股东总数'+NUMTOSTR(FINANCE(50),0)+'户'),ALIGN4,colorFF99FF;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1),CLOSE,' 红色百年独有资金坑技术'),ALIGN4,colorFFFF;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1),CLOSE,'           红色百年股票群74011259'),ALIGN3,colorFFFF;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1),CLOSE,'                      百年孤独;红蜻蜓牛年首发'),ALIGN5,colorFFFFFF;
多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1);
DRAWTEXT(CROSS(78.89,多方),HIGH*1.05,'逃'),colorFF00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),colorAAAAAA;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,6,0),colorBBBBBB;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.4,0),colorCCCCCC;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.1,0),colorDDDDDD;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0),colorCCCCCC;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0),colorCCCCCC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),color6666CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0),color7777DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),color8888EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.1,0),color9999FF;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),color1199FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0),color1199FF;
S3:=IF(DATE<=1090531,1,0);
AWE1:=3*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*1,5,1)-2*SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*1,5,1);
AWE2:=(EMA(AWE1,5)-REF(EMA(AWE1,5),1))/REF(EMA(AWE1,5),1)*1;
AWE3:=(IF(DATE>=N,IF(DATE<=M,1,0),0))*(S3);
AWE5:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*1;
DRAWTEXT(CROSS(AWE1,EMA(AWE1,5)) AND EMA(AWE1,5)<AWE5*AWE3,LOW*0.9,'(黑马)'),colorFFFF;{股票公式www.sportscountrycamp.com}
M55:MA(CLOSE,55),POINTDOT,LINETHICK4,colorFFFF;
A01:=(CLOSE-LLV(LOW,3))/(HHV(HIGH,3)-LLV(LOW,3));
A11:=SMA(A01,2,1);
A21:=SMA(A11,2,1);
A31:=3*A11-2*A21;
A41:=2*A31-0.5;
命:CLOSE*(1-(A41-A21)/15),LINETHICK2,colorFFFFFF;
弱:IF(MA(CLOSE,4)>SMA(LOW,21,2)*1.01,SMA(LOW,21,2)*1.01,SMA(LOW,21,2)*1.01),LINETHICK3,colorFF0000;
强:PARTLINE(SMA(LOW,21,2)*1.01>=REF(SMA(LOW,21,2)*1.01,1),SMA(LOW,21,2)*1.01),LINETHICK3,colorFF00FF;
阻:PEAK(1,5,1)*S3,color8000FF;
支:TROUGH(2,5,1),colorFFB97A;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=IF(DATE>=N,IF(DATE<=M,1,0),0);
VAR8:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),7,1))*100;
VAR9:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),13,1))*100;
VAR10:=(IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0))*VAR7;
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=VAR11+VAR13+VAR15+VAR17*VAR7;
卖1:=VAR12+VAR14+VAR16+VAR18*VAR7;
B:=PARTLINE(买1>0 OR 买2>0,LOW*0.99);
DRAWICON(买1>0 OR 买2>0,LOW*0.96,1),colorFF;
慧:=IF(卖1>0,HIGH*1.01,0);
孤:=IF(卖1>0,HIGH*1.01,0);
DRAWICON(卖1>0,HIGH*1.02,2);
VAR100:=100-90*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));
VAR200:=100-90*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));
VAR300:=100-MA(100*(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5)),34);
电话:=IF(CROSS(VAR200,MA(VAR300,5)),LOW*0.98,0);
VAR20:=EMA(AMOUNT/VOL/100,3);
VAR21:=EMA(VAR20,88);
VAR22:=EMA(VAR20,88)*0.85;
VARA:=VAR22*0.87;
VARB:=(LOW<VARA AND CLOSE>REF(CLOSE,1))*1.02;
DRAWICON(FILTER(VARB,6),LOW*0.96,1);
重:(CLOSE+0.618*REF(CLOSE,1)+0.382*REF(CLOSE,2)+0.236*REF(CLOSE,3)+0.146*REF(CLOSE,4))/2.382*S3,LINETHICK1,color1;
GAO:=HHV(CLOSE,60)-LLV(CLOSE,60);
RSI:=(SMA(MAX(重-REF(重,1),0),5,1))/(SMA(ABS(重-REF(重,1)),5,1));
平衡:=EMA(SLOPE(CLOSE,22)*20+CLOSE,55);
红多:PARTLINE(重>=平衡,平衡),LINETHICK3,colorFF;
绿空:PARTLINE(重<平衡,平衡),LINETHICK3,colorFF00;
SAT:=IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100>100,100,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100);
压1:=MA(REF(HHV(CLOSE,30),1),2);
支1:=MA(REF(LLV(CLOSE,30),1),2);
AA1:=AMOUNT/VOL;
BB1:=LOW<AA1*0.9;
CC1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>1.2;
DD1:=LOW<MA(CLOSE,5)*0.921;
EE1:=VOL<MA(VOL,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,LOW*0.9,'★老鼠仓'),color4080FF;
LC:=REF(CLOSE,1);
RSQ:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
MA16:=IF(DATE>=N,IF(DATE<=M,1,0),0);
DRAWTEXT(CROSS(FF,MA15*MA16),LOW*0.9,'★底背离'),colorFF00FF;
DRAWTEXT(CROSS(88,RSQ),支*0.96,'★顶背离'),colorFF00;
V2:=LLV(LOW,27);
V3:=HHV(HIGH,34);
V4:=EMA((CLOSE-V2)/(V3-V2)*4,4)*25;
注意买:=IF(V4<10,80,100);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
超跌:=IF(J<0,10,0);
BDDD:=LLV(J,2)=LLV(J,8);
买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,LOW*0.92,'★短'),colorE9C2A6;
VR3:=(2*CLOSE+HIGH+LOW)/4;
VR4:=LLV(LOW,34);
VR5:=HHV(HIGH,34);
GG:=HIGH*1.02;
SST:=IF(DATE>=N,IF(DATE<=M,1,0),0);
散户:=EMA((VR3-VR4)/(VR5-VR4)*100,13)*SST;
新庄:=EMA(0.667*REF(散户,1)+0.333*散户,2);
DRAWTEXT(CROSS(散户,30) AND 新庄<散户 AND ISLASTBAR,GG,'★注意调整 '),colorFF00;
DRAWTEXT(CROSS(散户,65) AND 新庄<散户 AND ISLASTBAR,GG,'★注意止盈 '),colorFF;
DRAWTEXT(CROSS(散户,75) AND 新庄<散户 AND ISLASTBAR,GG,'★小心被套 '),colorF0F000;
逢低吸呐:=CROSS(散户,新庄) AND 散户<40;
逢高减磅:=CROSS(新庄,散户) AND 新庄>5;
DRAWTEXT(逢低吸呐 AND ISLASTBAR,LOW*0.95,'★低吸'),colorFFFFFF;
DRAWTEXT(逢高减磅 AND ISLASTBAR,GG,'★逢高减磅'),colorFF;
PP:=(HIGH+LOW+CLOSE)/3;
PP1:=2*PP-LOW;
WX:=MA(CLOSE,0);
C1:=REF(CLOSE,1);
C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
MM:=BARSLAST(CLOSE<XB AND C1>=XB1);
M11:=REF(MM,1);
N9:=BARSLAST(CLOSE>ET AND C1<=ET1);
N1:=REF(N9,1);
M21:=(BARSLAST(MM-N9>0 AND M11<=N1))+1;
N2:=(BARSLAST(N9-MM>0 AND N1<=M11))+1;
ET2:=HHV(ET,M21);
XB2:=LLV(XB,N2);
A:=IF(MM-N9>0 AND M11<=N1,1,IF(N9-MM>0 AND N1<=M11,0,2));
H1:=IF(MM-N9>0,CLOSE,ET2);
H2:=IF(A=1,CLOSE,C2);
H3:=IF(MM-N9<0,CLOSE,XB2);
H4:=IF(A=1,CLOSE,XB2);
H5:=IF(MM-N9>0 OR A=1,CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=H5>H6;
H9:=H4=REF(H4,1) AND REF(H4,1)<REF(H4,2) AND H5>REF(H5,2);
H10:=H2=REF(H2,1) AND H4=REF(H4,1) AND H5=REF(H5,2);
W:=H8 OR H9 OR H10;
T9:=H5<H6 AND H5<REF(H5,2);
T10:=H4=REF(H4,1) AND H5<REF(H5,2);
T11:=H3>REF(H3,1) AND H5<REF(H5,1);
T12:=H5=REF(H5,1) AND H3=H4;
T13:=H2=REF(H2,1) AND H2=H5;
TW:=T9 OR T10 OR T11 OR T12 OR T13;
PK:=AMOUNT*(OPEN+CLOSE+HIGH+LOW)/4;
PK1:=IF(VOL>0,PK/AMOUNT,(OPEN+CLOSE+HIGH+LOW)/4);
BBP:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
SS:=W AND BBP<96.5;
TS:=ISLASTBAR=1;
DRAWTEXT(SS AND TS,LOW*0.89,'★明日看涨'),colorFF;
DRAWTEXT(TW AND TS AND BBP>1,HIGH*1.12,'明日看跌'),colorFF00;
KK3:=REF(CLOSE,1);
KK4:=(SMA(MAX(CLOSE-KK3,0),6,1))/(SMA(ABS(CLOSE-KK3),6,1))*100;
DRAWTEXT(CROSS(84,KK4),HIGH*1.08,'逃'),colorFFFF;
KK5:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
KK6:=(SMA(ABS(LOW-KK5),13,1))/(SMA(MAX(LOW-KK5,0),10,1));
KK7:=EMA(KK6,10);
KK8:=LLV(LOW,33)*SST;
KK9:=EMA(IF(LOW<=KK8,KK7,0),5);
主力进场:=FILTER(KK9>REF(KK9,1),5);
DRAWTEXT(FILTER(KK9>REF(KK9,1),5) AND ISLASTBAR,LOW*0.86,'主力进场'),colorFF;
DRAWTEXT(FILTER(KK5>REF(KK5,1),5) AND ISLASTBAR,LOW*1.08,'主力出场'),color70DB93;
EE3:=PEAKBARS(3,15,1)<10;
EE5:=IF(EE3=1,2,0);
顶:=IF(EE5=2,2,0);
顶A:=IF(顶>REF(顶,1),50,0);
DRAWTEXT(顶A=50,HIGH*1.03,'逃'),colorFF;
VKT0:=IF(DATE>=N,IF(DATE<=M,1,0),0);
VKT1:=PEAKBARS(3,15,1)<10;
VKT2:=IF(VKT1=1,2,0);
KTD:=IF(VKT2=2,2,0);
KTDA:=KTD>REF(KTD,1)*VKT0;
DRAWTEXT(KTDA,HIGH*1.04,'●黄金出逃点'),colorFFFF;
ASD:=BARSCOUNT(CLOSE);
AH:=HHV(HIGH,200);
AL:=LLV(LOW,200);
B0:=(AH-AL)/40;
B1:=HIGH+B0;
B2:=LOW-B0;
DRAWTEXT((ASD+0)/34=FLOOR((ASD+0)/34),支*0.93,'时间窗'),colorFFFFFF;
 

下载地址(点击下图进入下载地址网页)

    红色百年博弈下载

·上一软件:多空波段
·下一软件:A操盘指导员